Caterpillar Script Error - Printable Version

+- Save-Point (
+-- Forum: Games Development (
+--- Forum: Code Support (
+--- Thread: Caterpillar Script Error (/thread-750.html)

Pages: 1 2 3

Caterpillar Script Error - konterganon - 02-13-2010

Hey Guys, i've been using RMXP for quite some time now and my project is going well, but one simple script is causing me some trouble and seriously endangering the playability of my game.
The Caterpillar Script by Fukuyama

The Problem:
In Battle, when one of my characters dies, i will get an error saying "comparison float with float failed" (or something like that) on line 184
which is
case @move_list[i].type
i guess that it tries to display something during battle which it should only on the map...oO
Note: This doesnt happen everytime a character dies, just randomly.
Please Help.

[Resolved] Caterpillar Script Error - DerVVulfman - 02-13-2010

Erm... Glad to see you're as confused as I am. It shouldn't even bring that line up or access map character functions in the battlesystem. Confused

What battlesystem are you using?

[Resolved] Caterpillar Script Error - konterganon - 02-13-2010

the default one...
just some simple add ins:
XRXS's Full-View Battleback & Movable Camera ver.2
+ KGC_PreemptAttack

these are the only scripts i'm using that affect the battlesystem...afaik...
the problem is, that this error isnt really reproducable. i spent the last hour to get it again but it didnt even occur once. i did not change anything during that time.
its just really random...

[Resolved] Caterpillar Script Error - DerVVulfman - 02-13-2010

Confused And none of those even touch the Game_Map or Scene_Map or Game_Party code...

[Resolved] Caterpillar Script Error - konterganon - 02-13-2010

i just got the error again, this time it happened in the middle of a battle, no one died. it happened just before the execution of a skill.

this is a screenshot of the message:

would it somehow be possible to disable the whole caterpillar script upon the start of the battle scene?

uhh.. now i get the same error but MAIN oO

my main looks like this:
# ** Main
#  After defining each class, actual processing begins here.

  # Prepare for transition
  $defaultfontface = "Tahoma"
  $defaultfontsize = 24
  # Make scene object (title screen)
  $scene ="tis")"intro")
  # Call main method as long as $scene is effective
  while $scene != nil
  # Fade out
#rescue Errno::ENOENT
  # Supplement Errno::ENOENT exception
  # If unable to open file, display message and end
# filename = $!.message.sub("No such file or directory - ", "")
  #print("Unable to find file #{filename}.")

[Resolved] Caterpillar Script Error - kyonides - 02-14-2010

That main script let us think you're using a Postality Knights XP version... Have you tried to use the caterpillar script in the legal version of XP?

[Resolved] Caterpillar Script Error - konterganon - 02-14-2010

this main script is actually from my legal version. the entries like the $defaultfontface are for compatibility reasons since i'm using some very very old scripts (i've been working on this project for +-5 years now, maybe even longer).
is there a way to prove that im not usingra0a cracked version?

[Resolved] Caterpillar Script Error - DerVVulfman - 02-14-2010

Actually, your error messages screenshots do not show invalid or '?' replacement characters which would show up if you were using Postality Knights. Postality's was still set up in its .dlls and related programming to use the Japanese fonts and would show oddly. So, your error messages make me believe it's legit.

[Resolved] Caterpillar Script Error - konterganon - 02-14-2010

so, is there anything i can provide to help you get behind my problem?
i tried to disable the "buggy" part of the script by using game switches which would be activated before battle but the error just popped up in main...
my scripting skills and my understanding of ruby are very limited...

[Resolved] Caterpillar Script Error - DerVVulfman - 02-14-2010

The switch only makes the trailing characters visible/invisible on the map. Technically, it is always in play.

Perhaps you can provide a demo with the related scripts. Nothing entirely massive (you won't need any MP3s right?). Just something so someone can take a look and see about finding the problem.