Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 MultiSlots! / Charlie CTB Support
#1
Hey DerVVulfman. Great script, I really like the custom scene_equip. I hate to bother you with this but I cannot fix this error. It happens whenever I try to "battle test" from the database and when I try and equip a new weapon. From the map in test play.

Script 'mslots (RPG&Game)' line 410: NoMethodError occurred
undefined method 'cursed' for nil:NilClass

What's really weird is that if I try and equip anything else(shield, helmet, armor, etc.) then there is no error, it's only with the weapons. I am using this with Charlie Lee's CTB script, so maybe they are not compatible. However there is one exception to this error. If I am trying to "battle test", and I only have my summons in battle then it works. I am not sure if you know anything of the CTB but in the case that you do this is interesting. Also, if I try and equip a new weapon with the summons it also works. This is the part that confuses me, I am not sure why it would work with the summons and not the regular characters.

I have tried the putting "cursed" and "2H" on the weapons and I still get the error. I also tried giving the summons one of the weapons of the normal characters,(Ex. Arshes Bronze Sword), in test play and there was no error. I wish I could tell you more but I am have no idea why I am getting this error. FYI I am only using the 4 basic armor types: shield, helmet, armor, accessory, with only one slot in each. Thanks for any help.
Reply }
#2
nice script but that guy just crashed that idea with a bug report.
Reply }
#3
computerwizoo7 Wrote:nice script but that guy just crashed that idea with a bug report.
No he didn't.

habs11 Wrote:It happens whenever I try to "battle test" from the database and when I try and equip a new weapon. From the map in test play.

I am using this with Charlie Lee's CTB script, so maybe they are not compatible. However there is one exception to this error. If I am trying to "battle test", and I only have my summons in battle then it works. I am not sure if you know anything of the CTB but in the case that you do this is interesting.
I just downloaded his newest demo after testing MultiSlots with an old version 2.07 copy I had lying around. Both versions had no problems with MultiSlots. At least when I copied MultiSlots into the demo.

I pasted the whole MultiSlots system below all of the scripts (except Main), and then copied my li'l extra armors and weapons. Afterwhich, I made sure the 'switched armor/weapons' were properly definied. It's a guess, but I think you just need to copy MultiSlots to the bottom of your Script lists.
Reply }
#4
Alright, so I put the MultiSlots at the very bottom just above Main and I still got the error. Now I should I have mentioned that I am also using Charlie Lee's Skills Learning System add on. Sorry about that. However I wouldn't think there would be any conflict if I put the MultiSlot script below it, but then again, there could be some overlapping.

Ok, so I did some extensive testing see if I could find the root of the problem, and I think I found it. First, I slowly imported my settings into the CTB demo with MultiSlots. The Demo just had the CTB and MultiSlots, nothing else added. I encountered the same error when I imported the "armor" file in the "data" folder. I did some testing to find out that it is the Shield slot that is causing the error. The reason why my summons would work is because they had no equip-able shields(Just weapon and body armor for simplicity).

Now get this, in the MultiSlot config page I swictched around the order of the Armor_Slot_Types = [1, 2, 3, 4] to [2, 1, 3, 4] and it worked! No errors, ran smoothly. Your the boss when it comes to the scripts, so maybe you could figure out why it works when the order is different. Don't sweat it too much it's not the end of the world if I can't get it to work. Thanks for your time, I really appreciate it.
Reply }
#5
didn't you just said that it worked!?
Reply }
#6
computerwizoo7 Wrote:didn't you just said that it worked!?

Your right, I did get it to work. However it's only conditional. I would like to get it to work with all settings. But I'm not a scripter, so it's tough for me to change the lines of code to get things to work without messing everything else up. I just would like to know why I'm getting the error, that's all. I think from there it might be able to be fixed.

EDIT:

I found something else. If I assign no shield to the "initial equipment" of the actor, then there is no error. So to make it work I guess I could have a starting event that changed everyone's shield from nothing to the initial shield that they would be assigned to. That's just really weird. I guess I can make it work, but if anyone has any ideas to why it would work that way I would appreciate it, thanks.
Reply }
#7
Okay. Now I downloaded his 'Skill Learning/Equipment Skills' system and imported it into the system as follows:

Charlie Lee's CTB
The Skill Learning System
MultiSlots

In that order... and it still works fine without really any configuration issues, still using the default weapon/armor order.

I saw the area in Charlie's CTB demo where he 'reserved' a spot for the Skill Learning system. Other than the newer 'bar' script and such, I just posted his Learning system there. And like I stated before, I posted MultiSlots at the very end, just above Main.

Did you preserve that script order? Sometimes posting scripts above rather than below another script can cause difficulties.

Here's my working demo: >Click
Reply }
#8
I downloaded the demo too. There's actually a spot for the multi slot script as well, and it's before the SLS... honestly I don't remember why anymore, it seems that everything works in both ways.

I mean there are things that don't work... (like SKILL REQUIREMENTS, as the SLS only looks in the default weapon/armor slots in order to find weapon/armors required to cast spells. I will work on this issue), but no error message that stops the game.

I should mention that the CTB has some features that cannot work in the Battle Test from the Troops tab of the database, always test your battles in a map.
Reply }
#9
Ok, I have worked a bit with the newest version of the Skills Learning System, trying to solve all the compatibility issues with the Multi-Slot script.
Here's what I have done so far.
I'm working with an old version of the Multi-Slot script though, as it is the version I know better (it's the one that my Enhanced Weapons script is compatible with).
Reply }
#10
Alright so first I want to say thanks for everything you all have done, I really appreciate your time. Now, I have tested your Demo, DerVVulfman, and yes, it does work with the default "armors" file. However, if I try and use my "armors" file, then I get the error. I guess there is just something different about my set of armors, and I don't know what it could be. Now actually I didn't get any errors with Charlie's demo, but the multislot script he is using is different. I kind of like DerVVulfman's better, mainly because of the scene_equip. So I would try and stick to that one, but it gives me the error. However, like I mentioned above I can get around this error by simply starting each character with no shield, then having an initial event equipping them with the proper shield necessary. So, don't sweat it anymore. I can live with it if you can. If you really want to get to the bottom of this, I can try and send you my "armors" file and see if you can find anything wrong with it. Sorry to take up a bunch of your time, but this script was just too good not to use. Thanks again.
Reply }


Possibly Related Threads…
Thread Author Replies Views Last Post
   The Self Data Suite support thread PK8 0 3,445 07-18-2015, 09:41 PM
Last Post: PK8
   Help with CTB by Charlie fleed bswi13 2 4,367 06-17-2014, 11:08 PM
Last Post: bswi13
   Charlie Fleed's CTB - Issue with party formation JackMonty 2 4,785 02-06-2013, 02:21 PM
Last Post: JackMonty
   Advantages & Charlie Fleed CTB problem Yin 7 10,922 12-12-2011, 03:45 PM
Last Post: Yin
   Charlie Fleed's CTB - Problem with dual wielding characters MegaPowerNinja 2 5,348 04-25-2011, 09:51 AM
Last Post: Charlie Fleed
   FFX Battle system by Charlie Fleed RosyPosy 11 15,665 10-21-2010, 04:06 PM
Last Post: Charlie Fleed
   Actual 'Printer' support? DerVVulfman 4 7,137 04-18-2009, 10:06 PM
Last Post: Zeriab



Users browsing this thread: