Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Caterpillar Script Error
i didnt mean the visibility switch
i put " $game_switches[255] == false" (and "else" later) before line 184 so the following would only be executed if that switch was off, but the error just popped up in main instead of in train_actor.
i activated this switch right before battle and deativated it afterwards but it didnt help.

i'll try to come up with a small demo but idk if it will work because my project depends on a lot of files.
thank you for your help so far!
Reply }
alright, here comes the demo. i copied over the whole data folder minus all the maps (except 1).
but, i wasnt able to reproduce the error in the demo..its really strange.
Reply }
at least two people downloaded the demo.. still no comments?
i really need help with this one since it's rendering my whole project unplayable and thus many years of work for nothing.
i currently doubt that the error is restricted to the caterpillar script since the error seems to have shiftet to the last line of "main"...
Reply }
I am not a scripter but paste this in main:

Content Hidden

I didn't get any error but my main looks also like this, so try it^^
Reply }
thank you but the error keeps persistent.

Edit: i've made a quick video of the process in which the error occures:
Reply }
this error is really weird, I have never seen it before xD did you include all scripts in the demo? Seems that is has something to do with anything you took out of the demo.

In the video it seems like it has something to do with the dead of this skull.
Reply }
yup i did copy over all the scripts. i just copied over the "data" folder to the new demo project to guarantee that everything was included. (except the maps...)
the error seems only to occur when a game is loaded, never when a new game is started..
Reply }
really weird.... I loaded a save, fought against an enemy but this error didn't occure as well... does the same error occure on other maps?
Reply }
yes, it's the same on every map with battles. i could not get the error in the demo either. maybe thats the way, if i find the difference between the demo and my full project, i'll find the error^^
Reply }
DUDE!!! It just struck me when you said it happens after loading your 'save game'.

You are using a save game file created before you installed fukuyama's system, aren't you? It is a common problem that save games are not going to work properly after installing a new script because the new script has values that your save game is not accounting for. So... your old save game does not have the required @characters array.

All you have to do is make a new saved game file and continue with that one. Get rid of your old one. It won't work..
Reply }

Possibly Related Threads…
Thread Author Replies Views Last Post
   Script compatibility help Lord Vectra 3 3,675 07-25-2021, 11:42 PM
Last Post: DerVVulfman
   Adding face script on Cogwheel's RTAB Battle Status rekkatsu 15 13,253 08-25-2020, 03:09 AM
Last Post: DerVVulfman
   "Wait" in the script Whisper 13 13,981 04-28-2020, 04:06 PM
Last Post: Whisper
   Skill Cooldown script Fenriswolf 11 14,406 12-10-2019, 11:10 AM
Last Post: Fenriswolf
   (RMVXace) Battle error with Tankentai's battle system, help. x( Starmage 0 3,523 02-14-2018, 04:25 PM
Last Post: Starmage
   Help iwth script (RGSS Player crash) Whisper 3 7,736 06-17-2017, 05:03 PM
Last Post: Whisper
   Help modifying a script Keeroh 7 9,131 06-11-2017, 04:43 PM
Last Post: DerVVulfman
Question  Mog Menu script: help me stop the crazy picture movement during transitions Zachariad 4 8,790 05-31-2017, 05:10 AM
Last Post: Zachariad
   Actor names in Quest Script jreagan406 5 7,727 03-07-2017, 08:06 AM
Last Post: JayRay
  Expiration States with Atoa acbs: error Noctis 5 8,244 02-18-2017, 01:10 AM
Last Post: DerVVulfman

Users browsing this thread: