Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can Rpg Maker Xp run on Vista?
#1
Will rpg maker xp and its games run on windows vista?
if it won't then how can i get it to work?
Reply }
#2
Yes, it will run on Vista.

But, when you first install Vista, you'll run into a small problem with running RPG Maker XP (editor) that can be easily remedied. (Ntitles server error.) Find RPGXP.exe (It's in "C:\Windows\Program Files\Enterbrain\RPGXP", I'm sure), right click it, select Properties, click on the compatibility tab, check "Run this program in compatibility mode for:", select the Windows XP (Service Pack 2) option in the dropdown and check "Run in Administrator Mode".
Reply }
#3
Oh thanks!
That is good to hear, i was wondering if my Title would not make it to Vista Users.
Reply }
#4
Works perfectly fine here without any modification. (I only use a administrator account though here)
Reply }
#5
Well, I had a problem with vista that wouldn't go away. So I just downgraded to XP as hard as it was finding the drivers, I found them. :)
Reply }
#6
I've used a method and it works perfectly without ever having to look into it.
It doesn't require any drivers, downloads and what not.

Here's how:
1. Go to your root RMXP directory. C:\Program Files (x86)\Enterbrain\RPGXP\

2. Right click RPGXP.exe and choose "Properties".

3. In the "Properties" popup, go to the "Compatibility" tab.

4. Check the box that says "Run this program in compatibility mode for:" and select "Windows XP (Service Pack 2)"

5. Check the box that says "Run this program as an administrator".

6. If you cannot check the box mentioned in step 5, follow steps 7 through 11.

7. Click on the button that says "Show settings for all users".

8. Click the "OK" button on the "Windows needs your permission to continue" button, after inputting the password of the specified administrator if necessary.

9. Check the box that says "Run this program in compatibility mode for:" and select "Windows XP (Service Pack 2)"

10. Check the box that says "Run this program as an administrator".

11. Click the "OK" button.

12. Click the "OK" button.

13. Right click PSIKey.dll and choose "Properties".

14. In the "Properties" popup, go to the "Security" tab.

15. Click on the "Advanced" button.

16. Highlight the permission entry that says "Users ([your computer's name]\Users)" where [your computer's name] is whatever you named your computer.

17. Click the "Edit..." button.

18. Highlight the group "Users ([your computer's name]\Users)".

19. In the popup that appears (It should be named "Permission Entry for PSIKey.dll", check the "Allow" box for the option "Full Control".

20. All of the "Allow" boxes below the box you just checked should now be checked as well.

21. Click the "OK" Button.

22. Check the box that says "Include inheritable permissions from this object's parents".

23. Click the "OK" button.

24. Click the "OK" Button.

25. Click the "OK" Button.

26. Run RPG Maker XP, and you should no longer get any error messages!

27. If you still get the error message, log into the administrative account on the computer (With the owner's permission) and then run RPG Maker XP.
It should work no matter what on that account, after you have successfully completed the above steps.

Have fun playing and creating your own games! :D
Reply }


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rpg Maker eboot KasperKalamity 2 4,831 05-05-2012, 01:22 AM
Last Post: Taylor
  without rpg maker? KasperKalamity 2 4,316 10-24-2011, 04:43 AM
Last Post: Kristovski
  Issue with RPG Maker XP and VX XP Kobold 4 7,472 05-29-2011, 08:22 PM
Last Post: XP Kobold
  Generic RPG Maker XP Mapper Needed Xelrog T. Apocalypse 11 14,033 12-19-2010, 03:00 AM
Last Post: Xelrog T. Apocalypse



Users browsing this thread: